summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Larson <slioch@eng-140.vyatta.com>2008-06-18 19:39:05 -0700
committerMichael Larson <slioch@eng-140.vyatta.com>2008-06-18 19:39:05 -0700
commitbb4b1baf77ec14182de00d48767a00523282bbea (patch)
treed1679a0cd320a41ea3fa5f82ace7bddb6a9cb39d
parent97238661d34432eac6c8df62a28367da941f3e37 (diff)
parent2b12e94e3f19b694808fb2513f8e2a1e08eaec2d (diff)
downloadvyatta-cfg-bb4b1baf77ec14182de00d48767a00523282bbea.tar.gz
vyatta-cfg-bb4b1baf77ec14182de00d48767a00523282bbea.zip
Merge branch 'hollywood' of http://git.vyatta.com/vyatta-cfg into hollywood
-rw-r--r--debian/changelog107
-rwxr-xr-xetc/bash_completion.d/20vyatta-cfg60
2 files changed, 167 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 734169c..856faaf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,110 @@
+vyatta-cfg (0.10) unstable; urgency=low
+
+ 3.1.0
+ [ Mark O'Brien ]
+
+
+ [ Stig Thormodsrud ]
+ * Block reboot from config mode.
+ * Add exception for /31 and /32 for ipv4 and /128 for ipv6
+ * Fix 920: System allows configuration of invalid IP Address for
+ subnet
+
+ [ rbalocca ]
+ * Ignore log file
+ * Fix for bug #3274 https://bugzilla.vyatta.com/show_bug.cgi?id=3274
+
+ [ Stig Thormodsrud ]
+ * Force "protocols ospf parameters" to be committed before other ospf
+ config.
+
+ [ Stephen Hemminger ]
+ * Avoid any problems with non-device entries in /sys/class/net
+ * Remove unused dependencies
+
+ [ Stig Thormodsrud ]
+ * Fix vlan regex.
+
+ [ An-Cheng Huang ]
+ * fix for bug 3239: now support regex-based ordering for startup
+ config
+
+ [ Stig Thormodsrud ]
+ * Add more granularity to config rank (commit rip, ospf, bgp
+ separately).
+
+ [ rbalocca ]
+ * Fix problem with Default-Stop
+ * Convert to our method of changelog creation
+
+ [ Stig Thormodsrud ]
+ * Only check for dhcp client on eth, vlan, and bridge.
+ * Fix 3233 dhcp client doesn't work on bridge interface
+
+ [ An-Cheng Huang ]
+ * support "wildcard" ranking at boot time. only VRRP uses this for
+ now.
+ * partial fix for bug 3216: display escaped edit path correctly.
+
+ [ Michael Larson ]
+ * fix for show -all. note there is a change in how config files are
+ saved--only set values are now save as opposed to set
+
+ [ rbalocca ]
+ * Add parted debian package for install-system use
+
+ [ Michael Larson ]
+ * backing out show cmd change for now on existence of def
+ * final checkin as fix for bug 1219.
+ * mask out def markers in config script
+ * create def file to mark configuration nodes that are created by
+ default, rather than a node with a default value created by a
+ * modified fix for 2525--fixes problem introduced with last fix (bug
+ 3163)
+ * revert fix for 2525 until delete on commit warnings are resolved.
+ * reverse sort order on delete
+ * modified node ordering code.
+ * partial revert of priority support--will reapply after additional
+ changes.
+ * temp removal of free--possible corruption.
+ * support for node priority. higher value in node.def is higher
+ priority.
+
+ [ Mohit Mehta ]
+ * Fix Bug 3069 Help strings should be standardized
+
+ [ An-Cheng Huang ]
+ * partial fix for bug 2181: add new template field "priority".
+
+ [ Michael Larson ]
+ * alternate fix for 2525--force directory evaluation upstream.
+ * Revert "fix for bug 2525"
+
+ [ Mohit Mehta ]
+ * Fix Bug 3069 Help strings should be standardized
+
+ [ Michael Larson ]
+ * fix for bug 2525
+ * fix for bug 2549.
+ * fix for bug 2507
+
+ [ An-Cheng Huang ]
+ * fix for bug 2689: sort tag nodes appropriately
+
+ [ Mohit Mehta ]
+ * Fix Bug 2825 Load should read config file from default location when
+ no argument is provided.
+
+ [ Stig Thormodsrud ]
+ * Add vlan dependancy for vyatta-cfg.
+
+ [ rbalocca ]
+ * Fix a changelog problem
+
+ [ Mark O'Brien ]
+
+ -- Mark O'Brien <mobrien@firebolt.vyatta.com> Tue, 17 Jun 2008 09:26:38 -0700
+
vyatta-cfg (0.9) unstable; urgency=low
3.0.5
diff --git a/etc/bash_completion.d/20vyatta-cfg b/etc/bash_completion.d/20vyatta-cfg
index d77c933..d501019 100755
--- a/etc/bash_completion.d/20vyatta-cfg
+++ b/etc/bash_completion.d/20vyatta-cfg
@@ -135,6 +135,66 @@ top ()
set_config_ps1 ''
}
+rename()
+{
+ mvcp rename Rename mv "$@"
+}
+
+copy()
+{
+ mvcp copy Copy "cp -a" "$@"
+}
+
+mvcp ()
+{
+ local str=$1
+ shift
+ local Str=$1
+ shift
+ local cmd=$1
+ shift
+ local _otag=$1
+ local _ovalu=$2
+ local _to=$3
+ local _ntag=$4
+ local _nvalu=$5
+ local _oval=''
+ local _nval=''
+ local _mpath=${VYATTA_TEMP_CONFIG_DIR}/${VYATTA_EDIT_LEVEL}
+ local _tpath=${VYATTA_CONFIG_TEMPLATE}/${VYATTA_TEMPLATE_LEVEL}
+ vyatta_escape _ovalu _oval
+ vyatta_escape _nvalu _nval
+ if [ "$_to" != 'to' ] || [ -z "$_ntag" ] || [ -z "$_nval" ]; then
+ echo "Invalid $str command"
+ return 1
+ fi
+ if [ "$_otag" != "$_ntag" ]; then
+ echo "Cannot $str from \"$_otag\" to \"$_ntag\""
+ return 1
+ fi
+ if [ ! -d "$_tpath/$_otag/$VYATTA_TAG_NAME" ]; then
+ echo "Cannot $str under \"$_otag\""
+ return 1
+ fi
+ if [ ! -d "$_mpath/$_otag/$_oval" ]; then
+ echo "Configuration \"$_otag $_ovalu\" does not exist"
+ return 1
+ fi
+ if [ -d "$_mpath/$_ntag/$_nval" ]; then
+ echo "Configuration \"$_ntag $_nvalu\" already exists"
+ return 1
+ fi
+ if ! /opt/vyatta/sbin/my_set $_ntag "$_nvalu"; then
+ echo "$Str failed"
+ return 1
+ fi
+ /opt/vyatta/sbin/my_delete $_ntag "$_nvalu" >&/dev/null 3>&1
+
+ $cmd "$_mpath/$_otag/$_oval" "$_mpath/$_ntag/$_nval"
+
+ return 0
+}
+
edit ()
{
local num_comp=${#@}