summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-09-17 14:54:14 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-09-17 14:54:14 -0700
commitc5c35050fca8396968b64f5bffe070ed2b293c32 (patch)
tree3b285e002993d70aa704d85de933877248bce841
parent134f35f838d444d63a1774b986380264e7089c6e (diff)
parent13587019079b9d9a56dc9c4938794c822b8c5ee4 (diff)
downloadvyatta-cfg-c5c35050fca8396968b64f5bffe070ed2b293c32.tar.gz
vyatta-cfg-c5c35050fca8396968b64f5bffe070ed2b293c32.zip
Merge branch 'mendocino' of suva.vyatta.com:/git/vyatta-cfg into mendocino
-rw-r--r--debian/changelog6
-rw-r--r--src/cstore/unionfs/cstore-unionfs.cpp5
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c4ffc60..03b86a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg (0.17.18) unstable; urgency=low
+
+ * fix for bug 6195
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Tue, 14 Sep 2010 17:18:19 -0700
+
vyatta-cfg (0.17.17) unstable; urgency=low
* rebuild to link with latest apt
diff --git a/src/cstore/unionfs/cstore-unionfs.cpp b/src/cstore/unionfs/cstore-unionfs.cpp
index eebabfe..f125f37 100644
--- a/src/cstore/unionfs/cstore-unionfs.cpp
+++ b/src/cstore/unionfs/cstore-unionfs.cpp
@@ -997,11 +997,12 @@ UnionfsCstore::get_all_child_dir_names(b_fs::path root, vector<string>& nodes)
continue;
}
// name cannot start with "."
- if (di->path().file_string().substr(0, 1) == ".") {
+ string cname = di->path().filename();
+ if (cname.length() < 1 || cname[0] == '.') {
continue;
}
// found one
- nodes.push_back(_unescape_path_name(di->path().filename()));
+ nodes.push_back(_unescape_path_name(cname));
}
} catch (...) {
return;