summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-11-19 15:41:05 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-11-19 15:41:05 -0800
commit40fe9012a56a7cfdfa374108fa249d2a569112b8 (patch)
tree5d93d03e20df21d535736d584839b67bf12c29be
parent45ac9b1795456607fad9744870883489334e9b3c (diff)
parent39b7704d70df29cbd0a7a50eb851d7c5fb3afe2b (diff)
downloadvyatta-cfg-40fe9012a56a7cfdfa374108fa249d2a569112b8.tar.gz
vyatta-cfg-40fe9012a56a7cfdfa374108fa249d2a569112b8.zip
Merge branch 'mendocino' of suva.vyatta.com:/git/vyatta-cfg into mendocino
-rw-r--r--debian/changelog6
-rw-r--r--src/commit2.c2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4080b24..e0bc9ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg (0.18.33) unstable; urgency=low
+
+ * proper exit on failure.
+
+ -- Michael <mike@vyatta.com> Fri, 19 Nov 2010 07:30:20 -0800
+
vyatta-cfg (0.18.32) unstable; urgency=low
* fix for bug 6448
diff --git a/src/commit2.c b/src/commit2.c
index e1119b4..aeb9ce7 100644
--- a/src/commit2.c
+++ b/src/commit2.c
@@ -401,7 +401,7 @@ main(int argc, char** argv)
//remove tmp changes file as all the work is now done
unlink(COMMIT_CHANGES_FILE);
- exit (errors == 2);
+ exit (errors == 2 ? 0 : 1);
}