summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-08-02 12:30:41 -0500
committerJohn Southworth <john.southworth@vyatta.com>2011-08-02 12:30:41 -0500
commit61f8641e6cbb031b01118f460faa263dcbc19f2d (patch)
treef6916c095b49388bbb6d375fc454a3aec06f158f /Makefile.am
parent3276c3666befbf0d578065d861046d59b109fa93 (diff)
downloadvyatta-cfg-61f8641e6cbb031b01118f460faa263dcbc19f2d.tar.gz
vyatta-cfg-61f8641e6cbb031b01118f460faa263dcbc19f2d.zip
Reorganize the bash completion and command interpreter scripts into easier to manage chunks. Command interpreter is now in vyatta-cfg-run and common functions have been moved to vyatta-op
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f01ea8f..ec2dbaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,9 @@ initd_SCRIPTS = etc/init.d/vyatta-router
dhcphook_SCRIPTS = scripts/vyatta-dhclient-hook
logrotate_DATA = etc/logrotate.d/vyatta-config-logs
+interpdir = $(datadir)/vyatta-cfg/functions/interpreter/
+interp_DATA = functions/interpreter/vyatta-cfg-run
+
src/cparse/cparse.cpp: src/cparse/cparse.ypp src/cparse/cparse_def.h
bison -p cparse_ --defines=src/cparse/cparse.h -o $@ $<