summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2011-05-16 19:57:39 -0700
committerAn-Cheng Huang <ancheng@vyatta.com>2011-05-16 19:57:39 -0700
commit76ff750a6b057dacba1361726f15cd5bd4bfe14b (patch)
tree8eea69cfa6ba3377883d2caa4aeca874c100b2a3 /Makefile.am
parent7ea935bc47f37111b95ed8a4f989a2ae3f578e5a (diff)
downloadvyatta-cfg-76ff750a6b057dacba1361726f15cd5bd4bfe14b.tar.gz
vyatta-cfg-76ff750a6b057dacba1361726f15cd5bd4bfe14b.zip
reimplement commit hooks mechanism
* do NOT reinvent the wheel (directory traversal, sorting, script execution, etc.) when the functionality is already provided by the system. * eliminate hard-coded hook directory in various feastures. everyone should obtain the directory path from the config backend.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 78c1a66..8bcd723 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,6 @@ SUBDIRS = . perl_dmod
share_perl5dir = /opt/vyatta/share/perl5/Vyatta
completiondir = /etc/bash_completion.d
initddir = /etc/init.d
-commit_run_dir = /etc/commit
defaultdir = /etc/default
etc_shell_leveldir = $(sysconfdir)/shell/level
dhcphookdir = /etc/dhcp3/dhclient-exit-hooks.d
@@ -118,7 +117,6 @@ cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
- mkdir -p $(DESTDIR)$(commit_run_dir)
mkdir -p $(DESTDIR)$(etc_shell_leveldir)
cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)
cd $(DESTDIR)$(sbindir); \