summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-05-10 18:18:17 -0700
committerJohn Southworth <john.southworth@vyatta.com>2012-05-10 18:18:17 -0700
commitec497dc1a54c88784b380200508eba6a85f4cb97 (patch)
tree7a8c02cf54ab18f9d8e2049dd8f5057105c0d694 /Makefile.am
parente80a38f61e2321f0cde98f996e2c97dec2f389b6 (diff)
downloadvyatta-cfg-ec497dc1a54c88784b380200508eba6a85f4cb97.tar.gz
vyatta-cfg-ec497dc1a54c88784b380200508eba6a85f4cb97.zip
Bugfix 8079: fix require sys/ioctl.ph confilcts
perl only allows a require to be done once. If it is done in two included modules the module or function in the module used second doesn't have the data in the required file in its scope. To prevent this I created a third module that contains the functions that require 'sys/ioctl.ph' so that there is no longer a conflict.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a26054a..a6d5792 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,6 +107,7 @@ sbin_SCRIPTS += scripts/vyatta-log-commit.pl
share_perl5_DATA = lib/Vyatta/Config.pm
share_perl5_DATA += lib/Vyatta/File.pm
share_perl5_DATA += lib/Vyatta/Misc.pm
+share_perl5_DATA += lib/Vyatta/ioctl.pm
share_perl5_DATA += lib/Vyatta/Interface.pm
share_perl5_DATA += lib/Vyatta/TypeChecker.pm
share_perl5_DATA += lib/Vyatta/ConfigOutput.pm