summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2010-12-03 19:07:54 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2010-12-03 19:07:54 -0800
commited95fe7775d63a777d86779debcd1fd59e2d921f (patch)
tree39f6c331b7811cae00e2930009404362e37afdc9 /Makefile.am
parent814ec6da0379583108fd2d46dc90811b24fba359 (diff)
downloadvyatta-cfg-ed95fe7775d63a777d86779debcd1fd59e2d921f.tar.gz
vyatta-cfg-ed95fe7775d63a777d86779debcd1fd59e2d921f.zip
change boot-time config loading to use new implementation in backend.
* add new boot-time config loading script that uses shell API to access backend directly, bypassing wrapper. * use new loadFile implementation in the backend to perform the actual "load" operation (without "commit"). this reduces the "pre-commit" load time by ~60%.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 41baca7..9daed20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,7 +86,7 @@ sbin_SCRIPTS = scripts/vyatta-cfg-cmd-wrapper
sbin_SCRIPTS += scripts/vyatta-validate-type.pl
sbin_SCRIPTS += scripts/vyatta-find-type.pl
sbin_SCRIPTS += scripts/priority.pl
-sbin_SCRIPTS += scripts/vyatta-config-loader.pl
+sbin_SCRIPTS += scripts/vyatta-boot-config-loader
sbin_SCRIPTS += scripts/vyatta-config-gen-sets.pl
sbin_SCRIPTS += scripts/vyatta-cli-expand-var.pl
sbin_SCRIPTS += scripts/vyatta-output-config.pl