summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Larson <mike@ft1.vyatta.com>2009-09-09 16:27:42 -0700
committerMichael Larson <mike@ft1.vyatta.com>2009-09-09 16:27:42 -0700
commit09a684d6481868b501e5fb2df579ff6216dd111c (patch)
tree4c3443d073b30b6cbf04c21101ba1a51f3e8b37f /Makefile.am
parent5f1a33134d463fa565ee9dd43237252bd27d5fb3 (diff)
downloadvyatta-cfg-09a684d6481868b501e5fb2df579ff6216dd111c.tar.gz
vyatta-cfg-09a684d6481868b501e5fb2df579ff6216dd111c.zip
Priority file generator. This program will iterate over the complete template tree and build the
priority file from "priority: val" tags found in node.def files. This will now allow us to migrate the priority statements found to the specified nodes. Currently the program does not order the priority nodes according to values (cosmetic feature). Finally once all the priority values have been migrated to the infected node.defs the priority program can be added as a postinst hook on debian package install.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 217de7e..14a6cda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,14 +27,15 @@ CLEANFILES = src/cli_parse.c src/cli_parse.h src/cli_def.c src/cli_val.c
LDADD = src/libvyatta-cfg.la
LDADD += /usr/lib/libglib-2.0.la
-
-sbin_PROGRAMS = src/my_commit1
+sbin_PROGRAMS = src/priority
+sbin_PROGRAMS += src/my_commit1
sbin_PROGRAMS += src/my_commit2
sbin_PROGRAMS += src/exe_action
sbin_PROGRAMS += src/dump
sbin_PROGRAMS += src/my_delete
sbin_PROGRAMS += src/my_set
sbin_PROGRAMS += src/check_tmpl
+src_priority_SOURCES = src/priority.c
src_my_commit1_SOURCES = src/commit.c
src_my_commit2_SOURCES = src/commit2.c
src_exe_action_SOURCES = src/exe_action.c