summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-01-07 15:02:18 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-01-07 15:02:18 -0800
commit73026e8580afbbbbb18970679ff7207676b51ba6 (patch)
tree04d0aaa60de3ca48072f04dccdced9be483c674e /Makefile.am
parentebb8b5cdec70e45d155652f759eeb3bb889410c6 (diff)
downloadvyatta-cfg-73026e8580afbbbbb18970679ff7207676b51ba6.tar.gz
vyatta-cfg-73026e8580afbbbbb18970679ff7207676b51ba6.zip
New Vyatta::Interface infrastructure
Provide generic module to map interface name to configuration and other attributes. This is first step to ripping the special case code out of DHCP, QoS, ... that all have own rules for mapping name to configuration and configuration to name.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f7c14b0..f05abcb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,7 @@ sbin_SCRIPTS += scripts/vyatta-check-typeless-node.pl
share_perl5_DATA = lib/Vyatta/Config.pm
share_perl5_DATA += lib/Vyatta/Misc.pm
+share_perl5_DATA += lib/Vyatta/Interface.pm
share_perl5_DATA += lib/Vyatta/TypeChecker.pm
share_perl5_DATA += lib/Vyatta/ConfigDOMTree.pm
share_perl5_DATA += lib/Vyatta/ConfigOutput.pm
@@ -77,4 +78,4 @@ install-exec-hook:
mkdir -p $(DESTDIR)$(etc_shell_leveldir)
cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)
cd $(DESTDIR)/opt/vyatta/sbin; ln -s my_commit1 my_commit
- \ No newline at end of file
+