summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-12-07 18:19:48 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-12-07 18:19:48 -0800
commit04a54264cfc1041eb9ae238ccafab7f0e4be4a75 (patch)
treef3227b986435f2d88ade3255f406c658beb9a878 /Makefile.am
parentfd32d4dfaafe45c9a7fd4099423de36dd6600ef1 (diff)
downloadvyatta-cfg-04a54264cfc1041eb9ae238ccafab7f0e4be4a75.tar.gz
vyatta-cfg-04a54264cfc1041eb9ae238ccafab7f0e4be4a75.zip
add policy mechanism for user management: per-level policies control
default restricted mode and allowed op/cfg/pipe commands.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c757ac1..733526f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,8 @@ cfgdir = $(datadir)/vyatta-cfg/templates
share_perl5dir = /opt/vyatta/share/perl5
completiondir = /etc/bash_completion.d
initddir = /etc/init.d
+defaultdir = /etc/default
+etc_shell_leveldir = $(sysconfdir)/shell/level
AM_CFLAGS = -I src -Wall
AM_YFLAGS = -d --name-prefix=yy_`basename $* .y`_
@@ -43,9 +45,13 @@ share_perl5_DATA += scripts/VyattaConfigLoad.pm
share_perl5_DATA += scripts/VyattaMisc.pm
share_perl5_DATA += scripts/VyattaTypeChecker.pm
+default_DATA = etc/default/vyatta-cfg
+
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+ mkdir -p $(DESTDIR)$(etc_shell_leveldir)
+ cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)