summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBob Gilligan <gilligan@vyatta.com>2009-10-12 16:23:57 -0700
committerBob Gilligan <gilligan@vyatta.com>2009-10-12 16:23:57 -0700
commit565f1d0d9bfe9f6b4174c322f3f6bb78f52b453e (patch)
tree45a47351e08a5c8959f8dbfe5f10ce0c352b16d1 /Makefile.am
parent7f191f207e215edd672643a1d9fc90ef062d2503 (diff)
downloadvyatta-cfg-565f1d0d9bfe9f6b4174c322f3f6bb78f52b453e.tar.gz
vyatta-cfg-565f1d0d9bfe9f6b4174c322f3f6bb78f52b453e.zip
Bugfix 2593: Introduce automatic static IRQ affinity balancing for some NICs.
This change implements a mechanism for setting the IRQ affinity of NIC interrupts in a way that is optimally balanced. The affinity settings are static, and are set up at configuration time. I've added "auto" as a new legal value to the "interfaces ethernet ethX smp_affinity" configuration parameter. If this value is set, then the system attempts to perform automatic IRQ affinity assignment. At this time, automatic IRQ affinity is supported only for multiqueue NICs that use the igb or bnx2 drivers. Even with these two, differences in the organization of queues and their naming convention necessitate some NIC-specific code. The assignment strategy attempts to assign all queues of all NICs that share the same queue number to the same CPU. This has been shown to be optimal for IP forwarding workloads in 2.6.31 kernels. Setting the value to "auto" for NICs that use other drivers will be a no-op.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index faa68f7..54ef9d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,7 @@ sbin_SCRIPTS += scripts/vyatta-load-config.pl
sbin_SCRIPTS += scripts/vyatta-cfg-notify
sbin_SCRIPTS += scripts/vyatta-interfaces.pl
sbin_SCRIPTS += scripts/vyatta-irqaffin
+sbin_SCRIPTS += scripts/vyatta-auto-irqaffin.pl
sbin_SCRIPTS += scripts/vyatta-check-typeless-node.pl
sbin_SCRIPTS += scripts/vyatta-exists