summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Larson <slioch@slioch.vyatta.com>2010-06-05 09:48:06 -0700
committerMichael Larson <slioch@slioch.vyatta.com>2010-06-05 09:48:06 -0700
commit6fcaf773333e0285464e774751c95b79ec9c4ff5 (patch)
treeacbb76d9adf1e02c669a868f48969dffa648221c /Makefile.am
parenta15eb820c2a21546c39be544b69bd91b3f8a6b6c (diff)
downloadvyatta-cfg-6fcaf773333e0285464e774751c95b79ec9c4ff5.tar.gz
vyatta-cfg-6fcaf773333e0285464e774751c95b79ec9c4ff5.zip
add commit hook directory.
The entitlement bug can be fixed https://bugzilla.vyatta.com/show_bug.cgi?id=5354 by adding a hook into this directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index da03a83..bb03768 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
share_perl5dir = /opt/vyatta/share/perl5/Vyatta
completiondir = /etc/bash_completion.d
initddir = /etc/init.d
+commit_run_dir = /etc/commit
defaultdir = /etc/default
etc_shell_leveldir = $(sysconfdir)/shell/level
dhcphookdir = /etc/dhcp3/dhclient-exit-hooks.d
@@ -82,6 +83,7 @@ cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
+ mkdir -p $(DESTDIR)$(commit_run_dir)
mkdir -p $(DESTDIR)$(etc_shell_leveldir)
cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)
cd $(DESTDIR)/opt/vyatta/sbin; ln -s my_commit2 my_commit