summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-05-21 14:17:36 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-05-21 14:17:36 -0700
commit7d70cc23db917a04561e390ca039142ec1a0a6ff (patch)
tree771acf1d3023d69c97439e9b245a9f0a359cee58 /Makefile.am
parent0639cdb20357c3c1201d5a7012700373729c834a (diff)
downloadvyatta-cfg-7d70cc23db917a04561e390ca039142ec1a0a6ff.tar.gz
vyatta-cfg-7d70cc23db917a04561e390ca039142ec1a0a6ff.zip
Add command to get/set sysfs files
By using a command (instead of echo), it is possible to set capability and avoid sudo.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 69c10c7..efe1a92 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,8 @@ sbin_PROGRAMS += src/dump
sbin_PROGRAMS += src/my_delete
sbin_PROGRAMS += src/my_set
sbin_PROGRAMS += src/check_tmpl
+sbin_PROGRAMS += src/sysfs
+
src_priority_SOURCES = src/priority.c
src_my_commit2_SOURCES = src/commit2.c
src_exe_action_SOURCES = src/exe_action.c
@@ -39,6 +41,7 @@ src_dump_SOURCES = src/dump_session.c
src_my_delete_SOURCES = src/delete.c
src_my_set_SOURCES = src/set.c
src_check_tmpl_SOURCES = src/check_tmpl.c
+src_sysfs = src/sysfs.c
sbin_SCRIPTS = scripts/vyatta-cfg-cmd-wrapper
sbin_SCRIPTS += scripts/vyatta-validate-type.pl
@@ -77,4 +80,3 @@ install-exec-hook:
mkdir -p $(DESTDIR)$(etc_shell_leveldir)
cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)
cd $(DESTDIR)/opt/vyatta/sbin; ln -s my_commit2 my_commit
-