summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2008-11-13 15:29:31 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2008-11-13 15:29:31 -0800
commit167914b351409d752e6405735212f859b4b42c25 (patch)
treedc1531af555bfe9bb7d964b31f41777c66c6b9ed /debian/rules
parent47fd5a2c81f02c018669045b5f7faad0a3bfd571 (diff)
downloadvyatta-cfg-167914b351409d752e6405735212f859b4b42c25.tar.gz
vyatta-cfg-167914b351409d752e6405735212f859b4b42c25.zip
Optimize for size
Optimizing for size generates better code, especially on cache starved processors.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 244a67b..95634d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,7 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
PACKAGE=vyatta-cfg
PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g
configure = ./configure
configure += --host=$(DEB_HOST_GNU_TYPE)
@@ -31,7 +31,7 @@ configure += LDFLAGS="-Wl,-z,defs"
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
- CFLAGS += -O2
+ CFLAGS += -Os
endif
configure: configure.ac Makefile.am