summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-06-03 10:29:41 -0700
committerJohn Southworth <john.southworth@vyatta.com>2012-06-08 14:39:54 -0700
commita8b48e0dee8fcd9dbe602f8b09400d4082ca7d77 (patch)
treef3a5c67ed7ed393de0a548ce828c066dfcd89eca /debian/rules
parent3df95d3f999867e64d04604705f3d6f89fdad392 (diff)
downloadvyatta-cfg-a8b48e0dee8fcd9dbe602f8b09400d4082ca7d77.tar.gz
vyatta-cfg-a8b48e0dee8fcd9dbe602f8b09400d4082ca7d77.zip
Fix more load/commit memory leaks
This fixes some more of the memory leaks in load and commit. Some still exist in the legacy cli_new/cli_parse code. Since that code is supposed to be rewritten such that it interfaces with the rewritten commit code in a clean way, these will not be fixed right now.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules1
1 files changed, 1 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 59c7712..f2c57b7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,6 +10,7 @@ cfg_opts += --mandir=\$${prefix}/share/man
cfg_opts += --infodir=\$${prefix}/share/info
cfg_opts += CFLAGS="$(CFLAGS)"
cfg_opts += LDFLAGS="-Wl,-z,defs"
+cfg_opts += CXXFLAGS="$(CXXFLAGS)"
inst_opts := --sourcedir=debian/tmp
clean: