summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rwxr-xr-xetc/bash_completion.d/20vyatta-cfg4
-rw-r--r--templates/priority4
3 files changed, 16 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 41a8ffb..4a517e8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+vyatta-cfg (0.14.12) unstable; urgency=low
+
+ [ Stig Thormodsrud ]
+ * Force firewall group to be configured before firewall.
+
+ [ Stephen Hemminger ]
+ * Change order of config load
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Sun, 08 Feb 2009 15:47:06 -0800
+
vyatta-cfg (0.14.11) unstable; urgency=low
* Move config reload from quagga to vyatta-cfg
diff --git a/etc/bash_completion.d/20vyatta-cfg b/etc/bash_completion.d/20vyatta-cfg
index 369ef7a..5589d69 100755
--- a/etc/bash_completion.d/20vyatta-cfg
+++ b/etc/bash_completion.d/20vyatta-cfg
@@ -333,6 +333,10 @@ exit ()
# run op mode commands
run ()
{
+ if [ $# == 0 ]; then
+ echo Incomplete command
+ return 1
+ fi
_vyatta_op_run $@
}
diff --git a/templates/priority b/templates/priority
index 4e9d982..02db178 100644
--- a/templates/priority
+++ b/templates/priority
@@ -11,8 +11,8 @@
400 system
450 protocols/static
470 policy
-510 protocols/bgp/node.tag/neighbor/node.tag
-520 protocols/bgp/node.tag/parameters
+510 protocols/bgp/node.tag/parameters
+520 protocols/bgp/node.tag/neighbor/node.tag
530 protocols/bgp
600 protocols/ospf/parameters
610 protocols/ospf