summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rwxr-xr-xlib/Vyatta/Keepalived.pm1
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bbc6f63..c81e29c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg (0.15.43) unstable; urgency=low
+
+ * Fix 5133: vrrp transition scripts not working properly when going to
+ backup
+
+ -- Stig Thormodsrud <stig@vyatta.com> Tue, 01 Dec 2009 14:58:45 -0800
+
vyatta-cfg (0.15.42) unstable; urgency=low
[ Stephen Hemminger ]
diff --git a/lib/Vyatta/Keepalived.pm b/lib/Vyatta/Keepalived.pm
index 6d6a153..26a0a38 100755
--- a/lib/Vyatta/Keepalived.pm
+++ b/lib/Vyatta/Keepalived.pm
@@ -29,6 +29,7 @@ our @EXPORT = qw(get_conf_file get_state_script get_state_file
use base qw(Exporter);
use Vyatta::Config;
+use Vyatta::Interface;
use POSIX;
use strict;