summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control1
-rwxr-xr-xscripts/vyatta-config-loader.pl2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 1d04e20..c317ca4 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,7 @@ Depends: bash (>= 3.1),
procps (>= 1:3.2.7-3),
vyatta-quagga | quagga,
coreutils (>= 5.97-5.3),
+ bsdutils,
vyatta-op,
vyatta-config-migrate,
dhcp3-client | vyatta-dhcp3-client
diff --git a/scripts/vyatta-config-loader.pl b/scripts/vyatta-config-loader.pl
index 035d2af..370a669 100755
--- a/scripts/vyatta-config-loader.pl
+++ b/scripts/vyatta-config-loader.pl
@@ -9,7 +9,7 @@ use VyattaConfigLoad;
umask 0002;
if (!open(OLDOUT, ">&STDOUT") || !open(OLDERR, ">&STDERR")
- || !open(STDOUT, ">/var/log/config-boot.log")
+ || !open(STDOUT, "|/usr/bin/logger -t config-loader -p local0.debug")
|| !open(STDERR, ">&STDOUT")) {
print STDERR "Cannot dup STDOUT/STDERR: $!\n";
exit 1;