summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rwxr-xr-xlib/Vyatta/Config.pm2
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cb6f1be..3038169 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+vyatta-cfg (0.17.32) unstable; urgency=low
+
+ * allow error output to be accessed without config object.
+
+ -- root <root@debian.vyatta.com> Fri, 15 Oct 2010 15:04:49 -0700
+
+vyatta-cfg (0.17.31) unstable; urgency=low
+
+ * Ignore run_init unless running in selinux
+ * Have init reread inittab after config
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Thu, 14 Oct 2010 16:19:07 -0700
+
vyatta-cfg (0.17.30) unstable; urgency=low
* change location tag for error from reference: to errloc:
diff --git a/lib/Vyatta/Config.pm b/lib/Vyatta/Config.pm
index 1488c3d..e8fda29 100755
--- a/lib/Vyatta/Config.pm
+++ b/lib/Vyatta/Config.pm
@@ -677,7 +677,7 @@ sub compareValueLists {
}
sub outputError {
- my ($self, $location, $msg) = @_;
+ my ($location, $msg) = @_;
print STDERR $msg . "\n";
if (defined($ENV{VYATTA_OUTPUT_ERROR_LOCATION})) {
foreach my $elem (@$location) {