summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--src/commit2.c2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4080b24..e0bc9ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg (0.18.33) unstable; urgency=low
+
+ * proper exit on failure.
+
+ -- Michael <mike@vyatta.com> Fri, 19 Nov 2010 07:30:20 -0800
+
vyatta-cfg (0.18.32) unstable; urgency=low
* fix for bug 6448
diff --git a/src/commit2.c b/src/commit2.c
index e1119b4..aeb9ce7 100644
--- a/src/commit2.c
+++ b/src/commit2.c
@@ -401,7 +401,7 @@ main(int argc, char** argv)
//remove tmp changes file as all the work is now done
unlink(COMMIT_CHANGES_FILE);
- exit (errors == 2);
+ exit (errors == 2 ? 0 : 1);
}