summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rwxr-xr-xlib/Vyatta/Config.pm4
2 files changed, 13 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index c39c4b3..e9ab8ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+vyatta-cfg (0.18.57) unstable; urgency=low
+
+ * remove env check to inhibit errloc from API.
+
+ -- Michael Larson <mike@vyatta.com> Mon, 06 Dec 2010 16:32:51 -0800
+
+vyatta-cfg (0.18.56) unstable; urgency=low
+
+ * Add is_local_address to Misc.pm
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Mon, 06 Dec 2010 15:11:07 -0800
+
vyatta-cfg (0.18.55) unstable; urgency=low
* handle case for non-commit client with latest error location
diff --git a/lib/Vyatta/Config.pm b/lib/Vyatta/Config.pm
index 914230a..e66c317 100755
--- a/lib/Vyatta/Config.pm
+++ b/lib/Vyatta/Config.pm
@@ -693,9 +693,7 @@ sub compareValueLists {
sub outputError {
my ($location,$msg) = @_;
- if (defined($ENV{VYATTA_OUTPUT_ERROR_LOCATION})) {
- print STDERR "_errloc_:[" . join(" ",@{$location}) . "]\n";
- }
+ print STDERR "_errloc_:[" . join(" ",@{$location}) . "]\n";
print STDERR $msg . "\n";
}