summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--src/cstore/unionfs/cstore-unionfs.cpp5
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c4ffc60..03b86a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+vyatta-cfg (0.17.18) unstable; urgency=low
+
+ * fix for bug 6195
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Tue, 14 Sep 2010 17:18:19 -0700
+
vyatta-cfg (0.17.17) unstable; urgency=low
* rebuild to link with latest apt
diff --git a/src/cstore/unionfs/cstore-unionfs.cpp b/src/cstore/unionfs/cstore-unionfs.cpp
index eebabfe..f125f37 100644
--- a/src/cstore/unionfs/cstore-unionfs.cpp
+++ b/src/cstore/unionfs/cstore-unionfs.cpp
@@ -997,11 +997,12 @@ UnionfsCstore::get_all_child_dir_names(b_fs::path root, vector<string>& nodes)
continue;
}
// name cannot start with "."
- if (di->path().file_string().substr(0, 1) == ".") {
+ string cname = di->path().filename();
+ if (cname.length() < 1 || cname[0] == '.') {
continue;
}
// found one
- nodes.push_back(_unescape_path_name(di->path().filename()));
+ nodes.push_back(_unescape_path_name(cname));
}
} catch (...) {
return;