summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--src/cli_new.c3
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3cdff2d..c39c4b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg (0.18.55) unstable; urgency=low
+
+ * handle case for non-commit client with latest error location
+ changes.
+
+ -- Michael Larson <mike@vyatta.com> Mon, 06 Dec 2010 10:01:38 -0800
+
vyatta-cfg (0.18.54) unstable; urgency=low
* change boot-time config loading to use new implementation in
diff --git a/src/cli_new.c b/src/cli_new.c
index 821d21b..994280b 100644
--- a/src/cli_new.c
+++ b/src/cli_new.c
@@ -1276,6 +1276,9 @@ static boolean check_syn_func(vtw_node *cur,const char *prepend_msg,boolean form
OUTPUT_USER("_errloc_:[%s]\n%s\n\n",prepend_msg,exe_string);
}
}
+ else {
+ OUTPUT_USER("%s\n",exe_string);
+ }
}
}
}