diff options
-rw-r--r-- | .gitignore | 1 | ||||
-rw-r--r-- | configure.ac | 3 | ||||
-rw-r--r-- | debian/vyatta-cfg.postinst.in | 12 |
3 files changed, 15 insertions, 1 deletions
@@ -19,6 +19,7 @@ libtool /configure /debian/files /debian/vyatta-cfg +/debian/vyatta-cfg.postinst /INSTALL /Makefile.in /Makefile diff --git a/configure.ac b/configure.ac index f12cf4f..c108943 100644 --- a/configure.ac +++ b/configure.ac @@ -30,7 +30,8 @@ AC_ARG_ENABLE([nostrip], [NOSTRIP=-nostrip], [NOSTRIP=]) AC_CONFIG_FILES( - [Makefile]) + [Makefile] + [debian/vyatta-cfg.postinst]) AC_SUBST(NOSTRIP) diff --git a/debian/vyatta-cfg.postinst.in b/debian/vyatta-cfg.postinst.in new file mode 100644 index 0000000..6a5a3ec --- /dev/null +++ b/debian/vyatta-cfg.postinst.in @@ -0,0 +1,12 @@ +#!/bin/bash + +prefix=@prefix@ +sysconfdir=@sysconfdir@ + +# make sure config dir and config file dir are usable +for d in {$prefix,$sysconfdir}/config; do + mkdir -p $d + chgrp -R quaggavty $d + chmod -R g+w $d +done + |