summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/control3
-rwxr-xr-xscripts/vyatta-load-config.pl13
2 files changed, 10 insertions, 6 deletions
diff --git a/debian/control b/debian/control
index 308105a..5a06588 100644
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,8 @@ Depends: sed (>= 4.1.5),
vyatta-config-migrate,
dhcp3-client | vyatta-dhcp3-client,
bsdutils (>=1:2.13),
- libc6 (>= 2.7-6)
+ libc6 (>= 2.7-6),
+ vlan
Replaces: vyatta-cfg-firewall
Suggests: util-linux (>= 2.13-5),
net-tools,
diff --git a/scripts/vyatta-load-config.pl b/scripts/vyatta-load-config.pl
index 05323e3..9513ffa 100755
--- a/scripts/vyatta-load-config.pl
+++ b/scripts/vyatta-load-config.pl
@@ -28,16 +28,19 @@ use VyattaConfigLoad;
my $etcdir = $ENV{vyatta_sysconfdir};
my $sbindir = $ENV{vyatta_sbindir};
my $bootpath = $etcdir . "/config";
+my $load_file = $bootpath . "/config.boot";
-if ($#ARGV != 0) {
+if ($#ARGV > 0) {
print "Usage: load <config_file_name>\n";
exit 1;
}
-my $load_file = $ARGV[0];
-if (!($load_file =~ /^\//)) {
- # relative path
- $load_file = "$bootpath/$load_file";
+if (defined($ARGV[0])) {
+ $load_file = $ARGV[0];
+ if (!($load_file =~ /^\//)) {
+ # relative path
+ $load_file = "$bootpath/$load_file";
+ }
}
if (!open(CFG, "<$load_file")) {