summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rw-r--r--debian/vyatta-cfg.postinst.in8
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index feb160c..10e1156 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,8 @@ Depends: bash (>= 3.1),
procps (>= 1:3.2.7-3),
quagga,
coreutils (>= 5.97-5.3),
- vyatta-config-migrate
+ vyatta-config-migrate,
+ dhcp3-client
Suggests: util-linux (>= 2.13-5),
net-tools,
ethtool,
diff --git a/debian/vyatta-cfg.postinst.in b/debian/vyatta-cfg.postinst.in
index 05daf3b..4690c18 100644
--- a/debian/vyatta-cfg.postinst.in
+++ b/debian/vyatta-cfg.postinst.in
@@ -6,3 +6,11 @@ sysconfdir=@sysconfdir@
update-rc.d vyatta-ofr defaults 90 >/dev/null
# do we want to start vyatta-ofr here in postinst?
+if [ "$sysconfdir" != "/etc" ]; then
+ # remove the config files and replace with blank ones
+ for conf in dhcp3/dhclient.conf
+ do
+ [ -f /etc/$conf ] && mv -f /etc/$conf /etc/$conf.vyatta-save
+ touch /etc/$conf
+ done
+fi