summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 244a67b..b3c442a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,7 +17,7 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
PACKAGE=vyatta-cfg
PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-CFLAGS = -Wall -g
+CFLAGS = -Wall -g
configure = ./configure
configure += --host=$(DEB_HOST_GNU_TYPE)
@@ -31,7 +31,7 @@ configure += LDFLAGS="-Wl,-z,defs"
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
- CFLAGS += -O2
+ CFLAGS += -Os
endif
configure: configure.ac Makefile.am
@@ -88,7 +88,11 @@ binary-indep: build install
dh_compress
dh_fixperms
dh_installdeb
- dh_gencontrol
+ if [ -f "../.VYATTA_DEV_BUILD" ]; then \
+ dh_gencontrol -- -v999.dev; \
+ else \
+ dh_gencontrol; \
+ fi
dh_md5sums
dh_builddeb