summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/vyatta-cfg.install1
4 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b9d8a75..0c2b25a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+vyatta-cfg (0.102.0+vyos2+current2) unstable; urgency=low
+
+ [ Jason Hendry ]
+ * Adding python-vyos-mgmt library to the vyatta-cfg package
+
+ -- Jason Hendry <jasonhendry1987@gmail.com> Mon, 9 Jan 2017 10:18:00 +0000
+
vyatta-cfg (0.102.0+vyos2+current1) unstable; urgency=medium
[ Thomas Jepp ]
diff --git a/debian/control b/debian/control
index a44efc6..2048262 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: VyOS Package Maintainers <maintainers@vyos.net>
Build-Depends: debhelper (>= 5), autotools-dev, libglib2.0-dev,
libboost-filesystem1.55-dev, libapt-pkg-dev, libtool, flex,
bison, libperl-dev, autoconf, automake, pkg-config, cpio, dh-autoreconf ,dh-systemd,
- python3-setuptools, dh-python
+ python3-setuptools, dh-python, python3
Standards-Version: 3.9.1
Package: vyatta-cfg
diff --git a/debian/rules b/debian/rules
index 59eaab9..aa6b529 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,9 @@ export DH_OPTIONS
## uncomment to enable hardening
#export DEB_BUILD_HARDENING=1
+export PYBUILD_SYSTEM=distutils
+export PYBUILD_DIR=python
+
cfg_opts := --prefix=/opt/vyatta
cfg_opts += --libdir=/usr/lib
cfg_opts += --includedir=/usr/include
@@ -41,6 +44,7 @@ override_dh_auto_configure:
override_dh_auto_test:
override_dh_install:
+ pybuild
dh_install $(inst_opts)
override_dh_systemd_enable:
diff --git a/debian/vyatta-cfg.install b/debian/vyatta-cfg.install
index 8c9aca2..024be65 100644
--- a/debian/vyatta-cfg.install
+++ b/debian/vyatta-cfg.install
@@ -3,4 +3,5 @@ opt/vyatta/share/enumeration
opt/vyatta/share/vyatta-cfg/functions
opt/vyatta/sbin
opt/vyatta/etc
+usr/lib/python3.4/dist-packages/vyos
bin