From 576786c97065c8e5638e9e0a7cad688175cd3746 Mon Sep 17 00:00:00 2001
From: Kim <kim.sidney@gmail.com>
Date: Sun, 14 Oct 2018 21:33:06 +0200
Subject: Rework vyos router init (#11)

* Add a systemd vyos.target and split the vyatta-router
init script to multiple systemd scripts.

* remove ref to cloud-init

* Remove vyatta-router init and rename vyatta-router to vyos-initialize.

* Install files to correct dirs

* try to fix systemd boot issues

* Update script names
run config load in background to not block systemd

* Prevent cat: write error: Broken pipe

* Rework vyos startup

* add systemd to Makefile.am

* Update script name

* Fix inclusion of getty conf

* Fix indentation
---
 debian/rules | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'debian/rules')

diff --git a/debian/rules b/debian/rules
index eab1375..2603b2d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,9 @@
 #!/usr/bin/make -f
 
+DIR := debian/vyatta-cfg
+VYOS_LIBEXEC_DIR := usr/libexec/vyos
+SYSTEM_GENERATORS_DIR := lib/systemd/system-generators
+
 export DH_OPTIONS
 
 ## uncomment to enable hardening
@@ -44,5 +48,6 @@ override_dh_install:
 	dh_install $(inst_opts)
 
 override_dh_systemd_enable:
-	dh_systemd_enable -pvyatta-cfg --name vyatta-router vyatta-router.service
+	dh_systemd_enable -pvyatta-cfg --name vyos-router vyos-router.service
+	dh_systemd_enable -pvyatta-cfg --name vyos vyos.target
 
-- 
cgit v1.2.3