summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-12-17 14:46:33 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-12-17 14:46:33 -0800
commit41aac6942e89fa24b938ec188a0933e52acff623 (patch)
tree0a7a4046dd0bede6fd1a7fc8c8082a068cc6fbe3 /configure.ac
downloadvyatta-cluster-41aac6942e89fa24b938ec188a0933e52acff623.tar.gz
vyatta-cluster-41aac6942e89fa24b938ec188a0933e52acff623.zip
migrate clustering from fairfield to glendaleupstream
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..38b3cd2
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+
+m4_define([VERSION_ID], [m4_esyscmd([
+ if test -f .version ; then
+ head -n 1 .version | tr -d \\n
+ else
+ echo -n 2.4
+ fi])])
+AC_INIT([vyatta-cluster], VERSION_ID, [vyatta-support@vyatta.com])
+
+test -n "$VYATTA_VERSION" || VYATTA_VERSION=$PACKAGE_VERSION
+
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
+AC_PREFIX_DEFAULT([/opt/vyatta])
+
+AC_ARG_ENABLE([nostrip],
+ AC_HELP_STRING([--enable-nostrip],
+ [include -nostrip option during packaging]),
+ [NOSTRIP=-nostrip], [NOSTRIP=])
+
+AC_CONFIG_FILES(
+ [Makefile]
+ [debian/vyatta-cluster.postinst])
+
+AC_SUBST(NOSTRIP)
+
+AC_OUTPUT
+