summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrbalocca <rbalocca@vyatta.com>2008-05-07 14:50:38 -0700
committerrbalocca <rbalocca@vyatta.com>2008-05-07 14:50:38 -0700
commit5b0fe6b28c5d085c46d299af4dcf8f303dada9c4 (patch)
tree8da2670d889717788820240ca9e5b8c6fe1dbc30
parented84dc02de664778f67d410b136c7d92491178b1 (diff)
downloadvyatta-nat-5b0fe6b28c5d085c46d299af4dcf8f303dada9c4.tar.gz
vyatta-nat-5b0fe6b28c5d085c46d299af4dcf8f303dada9c4.zip
Convert to our method of changelog creation
-rw-r--r--.gitignore1
l---------ChangeLog1
-rwxr-xr-xdebian/autogen.sh26
3 files changed, 1 insertions, 27 deletions
diff --git a/.gitignore b/.gitignore
index 139f1b1..3a4c230 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,7 +3,6 @@
/aclocal.m4
/autom4te.cache
/build-stamp
-/ChangeLog
/config
/config.log
/config.guess
diff --git a/ChangeLog b/ChangeLog
new file mode 120000
index 0000000..d526672
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1 @@
+debian/changelog \ No newline at end of file
diff --git a/debian/autogen.sh b/debian/autogen.sh
index ff125d1..e8c94af 100755
--- a/debian/autogen.sh
+++ b/debian/autogen.sh
@@ -1,32 +1,6 @@
#!/bin/sh
-if [ -d .git ] ; then
-# generate GNU/Debian format ChangeLog from git log
-
- rm -f ChangeLog
-
- if which git2cl >/dev/null ; then
- git-log --pretty --numstat --summary | git2cl >> ChangeLog
- else
- git-log --pretty=short >> ChangeLog
- fi
-
-# append repository reference
-
- url=` git repo-config --get remote.origin.url`
- test "x$url" = "x" && url=`pwd`
-
- branch=`git-branch --no-color | sed '/^\* /!d; s/^\* //'`
- test "x$branch" = "x" && branch=master
-
- sha=`git log --pretty=oneline --no-color -n 1 | cut -c-8`
- test "x$sha" = "x" && sha=00000000
-
- echo "$url#$branch-$sha" >> ChangeLog
-
-fi
-
rm -rf config
rm -f aclocal.m4 config.guess config.statusconfig.sub configure INSTALL