summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-12-19 11:25:49 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-12-19 11:25:49 -0800
commit561ec07cb56696b05f683a325098c06422d00f86 (patch)
treeb35d1727c4de7775854948b862de652a78a0de44 /Makefile.am
downloadvyatta-nat-561ec07cb56696b05f683a325098c06422d00f86.tar.gz
vyatta-nat-561ec07cb56696b05f683a325098c06422d00f86.zip
migrate NAT from fairfield to glendaleupstream
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..850d7c9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+cfgdir = $(datadir)/vyatta-cfg/templates
+opdir = $(datadir)/vyatta-op/templates
+xsldir = $(datadir)/xsl
+share_perl5dir = $(datadir)/perl5
+bin_sudo_usersdir = $(bindir)/sudo-users
+
+sbin_SCRIPTS = scripts/vyatta-update-nat.pl
+bin_sudo_users_SCRIPTS = scripts/vyatta-show-nat.pl
+
+share_perl5_DATA = scripts/VyattaNatRule.pm
+
+cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
+ cpio -0pd
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(cfgdir)
+ cd templates-cfg; $(cpiop) $(DESTDIR)$(cfgdir)
+ mkdir -p $(DESTDIR)$(opdir)
+ cd templates-op; $(cpiop) $(DESTDIR)$(opdir)
+ mkdir -p $(DESTDIR)$(xsldir)
+ cd xsl; $(cpiop) $(DESTDIR)$(xsldir)