summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2007-12-19 11:25:49 -0800
committerAn-Cheng Huang <ancheng@vyatta.com>2007-12-19 11:25:49 -0800
commit561ec07cb56696b05f683a325098c06422d00f86 (patch)
treeb35d1727c4de7775854948b862de652a78a0de44 /configure.ac
downloadvyatta-nat-561ec07cb56696b05f683a325098c06422d00f86.tar.gz
vyatta-nat-561ec07cb56696b05f683a325098c06422d00f86.zip
migrate NAT from fairfield to glendaleupstream
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..15fd8e9
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,29 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+
+m4_define([VERSION_ID], [m4_esyscmd([
+ if test -f .version ; then
+ head -n 1 .version | tr -d \\n
+ else
+ echo -n 2.4
+ fi])])
+AC_INIT([vyatta-nat], VERSION_ID, [vyatta-support@vyatta.com])
+
+test -n "$VYATTA_VERSION" || VYATTA_VERSION=$PACKAGE_VERSION
+
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
+AC_PREFIX_DEFAULT([/opt/vyatta])
+
+AC_ARG_ENABLE([nostrip],
+ AC_HELP_STRING([--enable-nostrip],
+ [include -nostrip option during packaging]),
+ [NOSTRIP=-nostrip], [NOSTRIP=])
+
+AC_CONFIG_FILES(
+ [Makefile])
+
+AC_SUBST(NOSTRIP)
+
+AC_OUTPUT
+