summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2008-02-25 17:13:13 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2008-02-25 17:13:13 -0800
commit25756c49dc73cda4f00f09f9039af233c6cf4004 (patch)
treeec5df0673f05e0559aac551e2608eb25e887d2bd
parent3eb88b7d21d860b5d1af8fb5c9cc7c110a0d7848 (diff)
downloadvyatta-op-firewall-25756c49dc73cda4f00f09f9039af233c6cf4004.tar.gz
vyatta-op-firewall-25756c49dc73cda4f00f09f9039af233c6cf4004.zip
hold off this change until after Alpha 2 build
Revert "elminate use of sudo for iptables -L" This reverts commit 3eb88b7d21d860b5d1af8fb5c9cc7c110a0d7848.
-rw-r--r--Makefile.am4
-rw-r--r--templates/clear/firewall/name/node.tag/node.def2
-rw-r--r--templates/show/firewall/node.def2
-rw-r--r--templates/show/firewall/node.tag/detail/node.def2
-rw-r--r--templates/show/firewall/node.tag/detail/rule/node.tag/node.def3
-rw-r--r--templates/show/firewall/node.tag/node.def4
-rw-r--r--templates/show/firewall/node.tag/rule/node.tag/node.def2
-rw-r--r--templates/show/firewall/node.tag/statistics/node.def2
8 files changed, 11 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 6dc634e..6ba9848 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,9 +2,11 @@ opdir = $(datadir)/vyatta-op/templates
xsldir = @XSLDIR@
+bin_sudo_usersdir = $(bindir)/sudo-users
+
xsl_DATA =
-bin_SCRIPTS = scripts/firewall/vyatta-show-firewall.pl
+bin_sudo_users_SCRIPTS = scripts/firewall/vyatta-show-firewall.pl
xsl_DATA += src/xsl/show_firewall_detail.xsl
xsl_DATA += src/xsl/show_firewall_statistics_brief.xsl
diff --git a/templates/clear/firewall/name/node.tag/node.def b/templates/clear/firewall/name/node.tag/node.def
index 4d67bc1..6a61828 100644
--- a/templates/clear/firewall/name/node.tag/node.def
+++ b/templates/clear/firewall/name/node.tag/node.def
@@ -1,2 +1,2 @@
help: Clear firewall rules for a given chain
-allowed: /sbin/iptables --list -n | /bin/grep ^Chain | /usr/bin/awk '{ print $2 }'
+allowed: sudo ${vyatta_bindir}/sudo-users/iptables --list -n | /bin/grep ^Chain | /usr/bin/awk '{ print $2 }' \ No newline at end of file
diff --git a/templates/show/firewall/node.def b/templates/show/firewall/node.def
index 376c8e3..c27582d 100644
--- a/templates/show/firewall/node.def
+++ b/templates/show/firewall/node.def
@@ -1,3 +1,3 @@
help: Show firewall information
-run: ${vyatta_bindir}/vyatta-show-firewall.pl -all /opt/vyatta/share/xsl/show_firewall.xsl
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl -all /opt/vyatta/share/xsl/show_firewall.xsl
diff --git a/templates/show/firewall/node.tag/detail/node.def b/templates/show/firewall/node.tag/detail/node.def
index b3b65b6..f5295dd 100644
--- a/templates/show/firewall/node.tag/detail/node.def
+++ b/templates/show/firewall/node.tag/detail/node.def
@@ -1,3 +1,3 @@
help: Show firewall rules (detail output)
-run: ${vyatta_bindir}/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_detail.xsl
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_detail.xsl
diff --git a/templates/show/firewall/node.tag/detail/rule/node.tag/node.def b/templates/show/firewall/node.tag/detail/rule/node.tag/node.def
index 8456577..f3af458 100644
--- a/templates/show/firewall/node.tag/detail/rule/node.tag/node.def
+++ b/templates/show/firewall/node.tag/detail/rule/node.tag/node.def
@@ -1,5 +1,4 @@
help: Show detailed information about one firewall rule
allowed: echo -n "<NUMBER>"
-run: ${vyatta_bindir}/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_detail.xsl $6
-
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_detail.xsl $6
diff --git a/templates/show/firewall/node.tag/node.def b/templates/show/firewall/node.tag/node.def
index 74ce3cf..134ad7d 100644
--- a/templates/show/firewall/node.tag/node.def
+++ b/templates/show/firewall/node.tag/node.def
@@ -1,4 +1,4 @@
help: Show firewall rules for given chain
-allowed: /sbin/iptables --list -n | /bin/grep ^Chain | /usr/bin/awk '{ print $2 }'
-run: ${vyatta_bindir}/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall.xsl
+allowed: sudo ${vyatta_bindir}/sudo-users/iptables --list -n | /bin/grep ^Chain | /usr/bin/awk '{ print $2 }'
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall.xsl
diff --git a/templates/show/firewall/node.tag/rule/node.tag/node.def b/templates/show/firewall/node.tag/rule/node.tag/node.def
index 1bf5b47..cf252ed 100644
--- a/templates/show/firewall/node.tag/rule/node.tag/node.def
+++ b/templates/show/firewall/node.tag/rule/node.tag/node.def
@@ -1,4 +1,4 @@
help: Show firewall rules (summary output)
allowed: echo -n "<NUMBER>"
-run: ${vyatta_bindir}/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall.xsl $5
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall.xsl $5
diff --git a/templates/show/firewall/node.tag/statistics/node.def b/templates/show/firewall/node.tag/statistics/node.def
index 1897e12..fcbdddc 100644
--- a/templates/show/firewall/node.tag/statistics/node.def
+++ b/templates/show/firewall/node.tag/statistics/node.def
@@ -1,3 +1,3 @@
help: Show firewall counter information
-run: ${vyatta_bindir}/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_statistics.xsl
+run: sudo ${vyatta_bindir}/sudo-users/vyatta-show-firewall.pl $3 /opt/vyatta/share/xsl/show_firewall_statistics.xsl