summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d44534a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,22 @@
+opdir = $(datadir)/vyatta-op/templates
+
+xsldir = @XSLDIR@
+
+sbin_SCRIPTS =
+xsl_DATA =
+
+sbin_SCRIPTS += scripts/firewall/vyatta-show-firewall.pl
+
+xsl_DATA += src/xsl/show_firewall_detail.xsl
+xsl_DATA += src/xsl/show_firewall_statistics_brief.xsl
+xsl_DATA += src/xsl/show_firewall_statistics.xsl
+xsl_DATA += src/xsl/show_firewall.xsl
+
+cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
+ cpio -0pd
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(opdir)
+ cd templates; $(cpiop) $(DESTDIR)$(opdir)
+
+