summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-05-05 12:19:25 -0500
committerJohn Southworth <john.southworth@vyatta.com>2011-05-05 12:19:25 -0500
commitd9379eaf7c10563738c34a09964421b9762f0a1b (patch)
tree23e40a792af9119650c89753d93ec447c65f2961 /Makefile.am
parent279b0fa9490432ed4ebc87792d34fd315d53566b (diff)
downloadvyatta-op-vpn-d9379eaf7c10563738c34a09964421b9762f0a1b.tar.gz
vyatta-op-vpn-d9379eaf7c10563738c34a09964421b9762f0a1b.zip
Add ability to generate an x509 key pair (certificate signing request, private key)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7859933..ae1325d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,10 @@ cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
install-exec-hook:
+ mkdir -p $(DESTDIR)/opt/vyatta/etc/
+ mkdir -p $(DESTDIR)/opt/vyatta/sbin/
+ cp scripts/vyatta-gen-x509-keypair.sh $(DESTDIR)/opt/vyatta/sbin
+ cp scripts/key-pair.template $(DESTDIR)/opt/vyatta/etc
mkdir -p $(DESTDIR)$(opdir)
cd templates; $(cpiop) $(DESTDIR)$(opdir)