summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-03-29 16:15:02 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-03-29 16:15:02 -0700
commit8c7c6648dafdcf3e12af5ad904a78c784468b439 (patch)
treead24070b7d1bcaf21f467ede7670a1035f4c777e
parent9dc3fd49b7e37d33822cc2eea3a697be5d3f9e40 (diff)
downloadvyatta-op-8c7c6648dafdcf3e12af5ad904a78c784468b439.tar.gz
vyatta-op-8c7c6648dafdcf3e12af5ad904a78c784468b439.zip
Use new interface_description function
Show interfaces doesn't have to be in configure mode.
-rw-r--r--debian/control1
-rwxr-xr-xscripts/vyatta-show-interfaces.pl4
2 files changed, 2 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 2052a68..724c211 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,7 @@ Depends: sed (>= 4.1.5),
ntpdate,
procps (>= 1:3.2.7-3),
pciutils,
+ vyatta-cfg (>= 0.16.26),
vyatta-quagga (>= 0.99.15-26),
lsof,
coreutils (>= 5.97-5.3),
diff --git a/scripts/vyatta-show-interfaces.pl b/scripts/vyatta-show-interfaces.pl
index 1b662c8..6e071e2 100755
--- a/scripts/vyatta-show-interfaces.pl
+++ b/scripts/vyatta-show-interfaces.pl
@@ -57,10 +57,8 @@ my @tx_stat_vars =
sub get_intf_description {
my $name = shift;
- my $intf = new Vyatta::Interface($name);
- return "" unless $intf;
+ my $description = interface_description($name);
- my $description = $intf->description();
return "" unless $description;
return $description;
}