summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-03-01 00:54:04 +0000
committerJohn Southworth <john.southworth@vyatta.com>2012-03-01 00:54:04 +0000
commite7eb5130f92f84160a78575713fa1674d5fdac9c (patch)
tree579dda2dd3fd8e38eb8c83a011c8295380f49f9c
parent18dc119573592a0c6fbf224c0b75c25b3c967af1 (diff)
parent17b695105b5beb70eb5fd2b6433e521878e7aa41 (diff)
downloadvyatta-op-e7eb5130f92f84160a78575713fa1674d5fdac9c.tar.gz
vyatta-op-e7eb5130f92f84160a78575713fa1674d5fdac9c.zip
Merge branch 'oxnard' of git.vyatta.com:/git/vyatta-op into oxnard
-rw-r--r--debian/changelog18
-rw-r--r--scripts/rename-image.pl4
-rwxr-xr-xscripts/vyatta-boot-image.pl2
-rw-r--r--templates/monitor/interfaces/node.def1
4 files changed, 22 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e428c4b..2a60b98 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,21 @@
+vyatta-op (0.13.242) unstable; urgency=low
+
+ * bug fix for 7826 - fixed to use correct perl functions.
+
+ -- Deepti Kulkarni <deepti@vyatta.com> Wed, 29 Feb 2012 06:15:51 -0800
+
+vyatta-op (0.13.241) unstable; urgency=low
+
+ * Bugfix 4053: add missing top level 'monitor interfaces'
+
+ -- John Southworth <john.southworth@vyatta.com> Tue, 28 Feb 2012 12:49:20 -0800
+
+vyatta-op (0.13.240) unstable; urgency=low
+
+ * fix for bug 7719 - delete system image should accept 'y' or 'n'
+
+ -- Deepti Kulkarni <deepti@vyatta.com> Mon, 27 Feb 2012 05:08:05 -0800
+
vyatta-op (0.13.239) unstable; urgency=low
* Bugfix 4053: implement bandwidth utilization montior commands 'mon
diff --git a/scripts/rename-image.pl b/scripts/rename-image.pl
index be30967..6f3084c 100644
--- a/scripts/rename-image.pl
+++ b/scripts/rename-image.pl
@@ -119,10 +119,10 @@ while ($line = <$grubfh>) {
close($tmpfh);
close($grubfh);
-mv("$image_path/$old_name", "$image_path/$new_name")
+move("$image_path/$old_name", "$image_path/$new_name")
or die "rename $old_name to $new_name failed: $!\n";
-cp($tmpfilename, "$image_path/grub/grub.cfg")
+copy($tmpfilename, "$image_path/grub/grub.cfg")
or die "copy $tmpfilename to grub.cfg failed: $!\n";
syslog("warning", "System image $old_name has been renamed $new_name");
diff --git a/scripts/vyatta-boot-image.pl b/scripts/vyatta-boot-image.pl
index 2d53f1c..ef33658 100755
--- a/scripts/vyatta-boot-image.pl
+++ b/scripts/vyatta-boot-image.pl
@@ -481,7 +481,7 @@ sub doDelete {
}
chomp($resp);
$resp = lc($resp);
- if ($resp ne 'yes') {
+ if (($resp ne 'yes') && ($resp ne 'y')) {
print "Image is NOT deleted. Exiting...\n";
exit 1;
}
diff --git a/templates/monitor/interfaces/node.def b/templates/monitor/interfaces/node.def
index 9adbd67..ef09ad0 100644
--- a/templates/monitor/interfaces/node.def
+++ b/templates/monitor/interfaces/node.def
@@ -1 +1,2 @@
help: Monitor interfaces
+run: bmon -p !gre0,!sit0,!tunl0,!ip6tnl0;