summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2010-01-28 16:44:08 -0800
committerStephen Hemminger <stephen.hemminger@vyatta.com>2010-01-28 16:48:51 -0800
commita32dc00e1e7437e07e70ad3024fd80a867ad06cf (patch)
treea61d107433d82e1d46091890d047f23c9b094c5d
parentcba9b407840026da532f9f57f14784b2a183d6a0 (diff)
downloadvyatta-op-a32dc00e1e7437e07e70ad3024fd80a867ad06cf.tar.gz
vyatta-op-a32dc00e1e7437e07e70ad3024fd80a867ad06cf.zip
Expand all possible interfaces with leases for renew
Also mark all scripts as executable.
-rw-r--r--Makefile.am1
-rwxr-xr-xscripts/show-dhcp-leases.pl32
-rwxr-xr-x[-rw-r--r--]scripts/show-users.pl0
-rwxr-xr-x[-rw-r--r--]scripts/vyatta-identify-interface.pl0
-rwxr-xr-x[-rw-r--r--]scripts/vyatta-op-dns-forwarding.pl0
-rwxr-xr-x[-rw-r--r--]scripts/vyatta-op-dynamic-dns.pl0
-rwxr-xr-x[-rw-r--r--]scripts/vyatta-reboot.pl0
-rwxr-xr-x[-rw-r--r--]scripts/vyatta-tshark-interface-port.pl0
-rw-r--r--templates/release/dhcp/interface/node.tag/node.def6
-rw-r--r--templates/renew/dhcp/interface/node.tag/node.def6
10 files changed, 35 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index fd64da3..a2ae002 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,7 @@ bin_SCRIPTS += scripts/vyatta-cpu-summary.pl
bin_SCRIPTS += scripts/yesno
bin_SCRIPTS += scripts/vyatta-gettime.pl
bin_SCRIPTS += scripts/show-users.pl
+bin_SCRIPTS += scripts/show-dhcp-leases.pl
bin_SCRIPTS += scripts/vyatta-boot-image.pl
bin_SCRIPTS += scripts/vyatta-sudo
bin_SCRIPTS += scripts/vyatta-show-snmp.pl
diff --git a/scripts/show-dhcp-leases.pl b/scripts/show-dhcp-leases.pl
new file mode 100755
index 0000000..ce0c686
--- /dev/null
+++ b/scripts/show-dhcp-leases.pl
@@ -0,0 +1,32 @@
+#! /usr/bin/perl
+
+# **** License ****
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2 as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# This code was originally developed by Vyatta, Inc.
+# Portions created by Vyatta are Copyright (C) 2007 Vyatta, Inc.
+# All Rights Reserved.
+#
+# Author: Stephen Hemminger
+# Date: January 2010
+# Description: Show DHCP leases
+#
+# **** End License ****
+
+use strict;
+
+opendir (my $dir, "/var/lib/dhcp3");
+my @leases;
+while (my $f = readdir $dir) {
+ ($f =~ /^dhclient_(\w+)_lease$/) && push @leases, $1;
+}
+closedir $dir;
+
+print join(' ',@leases), "\n";
diff --git a/scripts/show-users.pl b/scripts/show-users.pl
index 8bd0825..8bd0825 100644..100755
--- a/scripts/show-users.pl
+++ b/scripts/show-users.pl
diff --git a/scripts/vyatta-identify-interface.pl b/scripts/vyatta-identify-interface.pl
index 0170b68..0170b68 100644..100755
--- a/scripts/vyatta-identify-interface.pl
+++ b/scripts/vyatta-identify-interface.pl
diff --git a/scripts/vyatta-op-dns-forwarding.pl b/scripts/vyatta-op-dns-forwarding.pl
index 5209e3e..5209e3e 100644..100755
--- a/scripts/vyatta-op-dns-forwarding.pl
+++ b/scripts/vyatta-op-dns-forwarding.pl
diff --git a/scripts/vyatta-op-dynamic-dns.pl b/scripts/vyatta-op-dynamic-dns.pl
index 3d24c38..3d24c38 100644..100755
--- a/scripts/vyatta-op-dynamic-dns.pl
+++ b/scripts/vyatta-op-dynamic-dns.pl
diff --git a/scripts/vyatta-reboot.pl b/scripts/vyatta-reboot.pl
index 2106ade..2106ade 100644..100755
--- a/scripts/vyatta-reboot.pl
+++ b/scripts/vyatta-reboot.pl
diff --git a/scripts/vyatta-tshark-interface-port.pl b/scripts/vyatta-tshark-interface-port.pl
index aa750e5..aa750e5 100644..100755
--- a/scripts/vyatta-tshark-interface-port.pl
+++ b/scripts/vyatta-tshark-interface-port.pl
diff --git a/templates/release/dhcp/interface/node.tag/node.def b/templates/release/dhcp/interface/node.tag/node.def
index a5cd912..f483278 100644
--- a/templates/release/dhcp/interface/node.tag/node.def
+++ b/templates/release/dhcp/interface/node.tag/node.def
@@ -1,7 +1,3 @@
help: Release DHCP IP address lease for specified interface
-allowed:
- local -a array ;
- array=( /var/lib/dhcp3/eth* /var/lib/dhcp3/br* /var/lib/dhcp3/bond* ) ;
- echo -n ${array[@]##*/}
-
+allowed: /opt/vyatta/bin/show-dhcp-leases.pl
run: sudo /opt/vyatta/bin/sudo-users/vyatta-interfaces.pl --dhcp release --dev "$4"
diff --git a/templates/renew/dhcp/interface/node.tag/node.def b/templates/renew/dhcp/interface/node.tag/node.def
index ab6494d..7705a83 100644
--- a/templates/renew/dhcp/interface/node.tag/node.def
+++ b/templates/renew/dhcp/interface/node.tag/node.def
@@ -1,7 +1,3 @@
help: Renew DHCP IP address lease for specified interface
-allowed:
- local -a array ;
- array=( /var/lib/dhcp3/eth* /var/lib/dhcp3/br* /var/lib/dhcp3/bond* ) ;
- echo -n ${array[@]##*/}
-
+allowed: /opt/vyatta/bin/show-dhcp-leases.pl
run: sudo /opt/vyatta/bin/sudo-users/vyatta-interfaces.pl --dhcp renew --dev "$4"