summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2012-05-15 11:34:33 -0700
committerJohn Southworth <john.southworth@vyatta.com>2012-05-15 11:34:33 -0700
commit6325118d9aa1ae7890a29c6f211ce456d04d68a9 (patch)
treed6cbbcad7acb4cd01cf520eff96e1641bd6a175f /Makefile.am
parent0da3c8a7e5b7506a4b9a7d1bedbd48fd45e7d89d (diff)
downloadvyatta-op-6325118d9aa1ae7890a29c6f211ce456d04d68a9.tar.gz
vyatta-op-6325118d9aa1ae7890a29c6f211ce456d04d68a9.zip
Add Vyatta wrappers for new keepalived output
1. Move show and clear vrrp scripts from vyatta-cfg-system. These belong in vyatta-op. 2. Create templates for new vrrp commands 3. Make show commands go through a perl module so they can be referenced from the webgui.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 99f5da6..2d82760 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,7 @@ completion_DATA = etc/bash_completion.d/vyatta-op
opdir = $(datadir)/vyatta-op/templates
bin_sudo_usersdir = $(bindir)/sudo-users
etc_shell_leveldir = $(sysconfdir)/shell/level
+share_perl5dir = $(datarootdir)/perl5/Vyatta/VRRP/
funcdir = $(datadir)/vyatta-op/functions
func_DATA = functions/tech-support
@@ -58,6 +59,10 @@ bin_sudo_users_SCRIPTS += scripts/vyatta-reboot.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-op-dns-forwarding.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-op-dynamic-dns.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-clear-conntrack
+bin_sudo_users_SCRIPTS += scripts/vrrp/vyatta-clear-vrrp.pl
+bin_sudo_users_SCRIPTS += scripts/vrrp/vyatta-show-vrrp.pl
+
+share_perl5_DATA = lib/Vyatta/VRRP/OPMode.pm
all-local:
./gen-unpriv-commands.sh