summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-08-16 18:26:24 -0500
committerJohn Southworth <john.southworth@vyatta.com>2011-10-27 17:11:27 -0500
commitb1c37ed9fe0e2cfac2ac46d757c6037c1c5436c2 (patch)
tree7b9b6d104a9f1feeceee34b6f05162cbc488a77e /Makefile.am
parent489df817f907a5dab7e177412fee7da8a970a309 (diff)
downloadvyatta-op-b1c37ed9fe0e2cfac2ac46d757c6037c1c5436c2.tar.gz
vyatta-op-b1c37ed9fe0e2cfac2ac46d757c6037c1c5436c2.zip
Create new ping command with the following semantics
1. ping <ipv4|ipv6|hostname> will use * ping for a v4 address * ping6 for a v6 address * ping or ping6 for a hostname which ever resolves prefering ipv4 2. ping ipv4 <ipv4|hostname> will ping 3. ping ipv6 <ipv6|hostname> will ping6 4. ping <node> option <advanced ping options> * allows for options to pass down to ping * this is a stop gap while we add the most common options * to the CLI (cherry picked from commit 5145fd68da8f1c7f8289b99f58cb6eb96389fcef)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d1f98ff..ca03fb1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,7 @@ bin_SCRIPTS += scripts/vyatta-remote-copy.pl
bin_SCRIPTS += scripts/vyatta-show-current-user
bin_SCRIPTS += scripts/tech-support-archive
bin_SCRIPTS += scripts/vyatta-op-cmd-wrapper
+bin_SCRIPTS += scripts/vyatta-ping
sbin_SCRIPTS = scripts/dhcpv6-client-show-leases.pl
sbin_SCRIPTS += scripts/vyatta-image-tools.pl