summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Davidson <james.davidson@vyatta.com>2013-04-25 14:27:39 -0700
committerJames Davidson <james.davidson@vyatta.com>2013-04-26 11:38:29 -0700
commit88a21f1388a8e0599864d31c36edb42c738c7978 (patch)
tree734ad59c95dbf506d39c25453f0f243bbf4bed66 /Makefile.am
parentdb838e8e080d257d8b7b40f049a498c04e88690d (diff)
downloadvyatta-op-88a21f1388a8e0599864d31c36edb42c738c7978.tar.gz
vyatta-op-88a21f1388a8e0599864d31c36edb42c738c7978.zip
Use node generation scripts in build
For the nodes that the generation scripts generate, delete the checked in node files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0205f74..9c39def 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,6 +62,11 @@ bin_sudo_users_SCRIPTS += scripts/vyatta-clear-conntrack
all-local:
./gen-unpriv-commands.sh
+ ./gen-monitor-interface-templates.sh
+ ./gen-monitor-vif-interface-templates.sh
+
+clean-local:
+ $(RM) -r generated-templates
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
@@ -69,6 +74,7 @@ cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
install-exec-hook:
mkdir -p $(DESTDIR)$(opdir)
cd templates; $(cpiop) $(DESTDIR)$(opdir)
+ cd generated-templates && $(cpiop) $(DESTDIR)$(opdir)
mkdir -p $(DESTDIR)$(etc_shell_leveldir)
cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)
mkdir -p $(DESTDIR)/etc/