summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn Southworth <john.southworth@vyatta.com>2011-08-03 11:59:21 -0500
committerJohn Southworth <john.southworth@vyatta.com>2011-08-03 11:59:21 -0500
commitf6e3d3d687bdc82e4fa885864b35d9d7aa9ed5ca (patch)
treef15084d2df351671952e98b5da2bb7d4df74fcb8 /Makefile.am
parent5881df96b478d388813557d7280e55e788b5e175 (diff)
downloadvyatta-op-f6e3d3d687bdc82e4fa885864b35d9d7aa9ed5ca.tar.gz
vyatta-op-f6e3d3d687bdc82e4fa885864b35d9d7aa9ed5ca.zip
Generate unpriviledged allowed-op at compile time. Add script to allow admin user to regenerate it if needed. Fix ambiguous command message.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cc0758..d1f98ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,6 +4,7 @@ completiondir = /etc/bash_completion.d
completion_DATA = etc/bash_completion.d/vyatta-op
opdir = $(datadir)/vyatta-op/templates
bin_sudo_usersdir = $(bindir)/sudo-users
+etc_shell_leveldir = $(sysconfdir)/shell/level
funcdir = $(datadir)/vyatta-op/functions
func_DATA = functions/tech-support
@@ -11,9 +12,11 @@ func_DATA += functions/tech-support-brief
interpdir = $(datadir)/vyatta-op/functions/interpreter
interp_DATA = functions/interpreter/vyatta-op-run
+interp_DATA += functions/interpreter/vyatta-unpriv
interp_DATA += functions/interpreter/vyatta-common
interp_DATA += functions/interpreter/vyatta-image-complete
+
bin_SCRIPTS = scripts/vyatta-show-interfaces
bin_SCRIPTS += scripts/vyatta-show-interfaces.pl
bin_SCRIPTS += scripts/vyatta-show-version
@@ -39,6 +42,7 @@ bin_SCRIPTS += scripts/vyatta-op-cmd-wrapper
sbin_SCRIPTS = scripts/dhcpv6-client-show-leases.pl
sbin_SCRIPTS += scripts/vyatta-image-tools.pl
+sbin_SCRIPTS += scripts/vyatta-regen-unpriv-commands.sh
bin_sudo_users_SCRIPTS = scripts/vyatta-identify-interface.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-delete-log-file.sh
@@ -47,9 +51,14 @@ bin_sudo_users_SCRIPTS += scripts/vyatta-op-dns-forwarding.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-op-dynamic-dns.pl
bin_sudo_users_SCRIPTS += scripts/vyatta-clear-conntrack
+all-local:
+ ./gen-unpriv-commands.sh
+
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
install-exec-hook:
mkdir -p $(DESTDIR)$(opdir)
cd templates; $(cpiop) $(DESTDIR)$(opdir)
+ mkdir -p $(DESTDIR)$(etc_shell_leveldir)
+ cd etc/shell/level; $(cpiop) $(DESTDIR)$(etc_shell_leveldir)