summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@vyatta.com>2007-09-14 18:32:41 -0700
committerTom Grennan <tgrennan@vyatta.com>2007-09-14 18:32:41 -0700
commit44960aef3c4b9a10a16ca39ff9f8a0e2e9d069cf (patch)
tree1719340d148647348af1f0c6394cc794a76ac67c /configure.ac
downloadvyatta-op-44960aef3c4b9a10a16ca39ff9f8a0e2e9d069cf.tar.gz
vyatta-op-44960aef3c4b9a10a16ca39ff9f8a0e2e9d069cf.zip
initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..631597b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+
+m4_define([VERSION_ID], [m4_esyscmd([
+ if test -f .version ; then
+ head -n 1 .version | tr -d \\n
+ else
+ echo -n 2.4
+ fi])])
+AC_INIT([vyatta-op], VERSION_ID, [vyatta-support@vyatta.com])
+
+test -n "$VYATTA_VERSION" || VYATTA_VERSION=$PACKAGE_VERSION
+
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
+AC_PREFIX_DEFAULT([/opt/vyatta])
+
+AC_ARG_ENABLE([nostrip],
+ AC_HELP_STRING([--enable-nostrip],
+ [include -nostrip option during packaging]),
+ [NOSTRIP=-nostrip], [NOSTRIP=])
+
+AC_CONFIG_FILES(
+ [Makefile]
+ [etc/default/vyatta])
+
+AC_SUBST(NOSTRIP)
+
+AC_OUTPUT
+