summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@vyatta.com>2008-03-20 13:46:50 -0700
committerTom Grennan <tgrennan@vyatta.com>2008-03-20 13:46:50 -0700
commite2981f89122e5cd812b36eddb4ff242e5a77c5c8 (patch)
treecc1b6356a5ecc87910ad573df6e74d9cbffa0228 /debian/rules
parent6695763f68fbf3acfb6c69739deca28217eaf8ef (diff)
downloadvyatta-op-e2981f89122e5cd812b36eddb4ff242e5a77c5c8.tar.gz
vyatta-op-e2981f89122e5cd812b36eddb4ff242e5a77c5c8.zip
this is an architecture independent package
so, remove the architecture specific configuration tests to speed-up build
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 0 insertions, 19 deletions
diff --git a/debian/rules b/debian/rules
index f2e5c13..4db6686 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,30 +9,13 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
PACKAGE=vyatta-op
PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-CFLAGS = -Wall -g
-
configure = ./configure
-configure += --host=$(DEB_HOST_GNU_TYPE)
-configure += --build=$(DEB_BUILD_GNU_TYPE)
configure += --prefix=/opt/vyatta
configure += --mandir=\$${prefix}/share/man
configure += --infodir=\$${prefix}/share/info
-configure += CFLAGS="$(CFLAGS)"
-configure += LDFLAGS="-Wl,-z,defs"
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
configure: configure.ac Makefile.am
chmod +x debian/autogen.sh
@@ -84,8 +67,6 @@ binary-indep: build install
dh_installdocs
dh_install
dh_installdebconf
- dh_link
- dh_strip
dh_compress
dh_fixperms
dh_installdeb