summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@io.vyatta.com>2007-12-05 12:33:05 -0800
committerTom Grennan <tgrennan@io.vyatta.com>2007-12-05 12:33:05 -0800
commitf260a55468cbfef7faf567c5f6b5b6c2bec28008 (patch)
tree7e81b2c8e2e68121999419ae2e358aa333097580 /debian
parent5e0e3f2e6d589d5912776b01346b15adf5c44982 (diff)
parent2f9ea52c4ed0415509dcdd8c786da773cefc041b (diff)
downloadvyatta-op-f260a55468cbfef7faf567c5f6b5b6c2bec28008.tar.gz
vyatta-op-f260a55468cbfef7faf567c5f6b5b6c2bec28008.zip
Merge branch 'master' of http://phuket.vyatta.com/vyatta-op
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rw-r--r--debian/vyatta-op.postinst.in9
-rw-r--r--debian/vyatta-op.postrm.in11
3 files changed, 22 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 3517600..a5c9b9f 100644
--- a/debian/control
+++ b/debian/control
@@ -9,12 +9,12 @@ Package: vyatta-op
Architecture: all
Depends: bash (>= 3.1),
sed (>= 4.1.5),
+ ethtool,
+ ntpdate,
procps (>= 1:3.2.7-3),
coreutils (>= 5.97-5.3)
Suggests: util-linux (>= 2.13-5),
net-tools,
- ethtool,
ncurses-bin (>= 5.5-5),
- ntpdate
Description: bash operational command completion
Vyatta operational command bash completion script and base templates
diff --git a/debian/vyatta-op.postinst.in b/debian/vyatta-op.postinst.in
new file mode 100644
index 0000000..b95d509
--- /dev/null
+++ b/debian/vyatta-op.postinst.in
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+bindir=@bindir@
+
+# add symlinks for sudo
+ln -sf /usr/sbin/ethtool ${bindir}/sudo-users/ethtool
+
diff --git a/debian/vyatta-op.postrm.in b/debian/vyatta-op.postrm.in
new file mode 100644
index 0000000..75d77ca
--- /dev/null
+++ b/debian/vyatta-op.postrm.in
@@ -0,0 +1,11 @@
+#!/bin/bash
+
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+bindir=@bindir@
+
+if [ "$1" = "purge" ]; then
+ # remove added symlinks
+ rm -f ${bindir}/sudo-users/ethtool
+fi
+