summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTom Grennan <tgrennan@vyatta.com>2007-09-20 18:43:23 -0700
committerTom Grennan <tgrennan@vyatta.com>2007-09-20 18:43:23 -0700
commit00b78e597b6e3aa1fd65ffdd7ea1ff2a2ac019d5 (patch)
treefcb84cdd6185730b49f58621ed751dae9e790d51 /debian
parent64e83f470a7076b63bd9b76c7b6bb516cbe9bb92 (diff)
downloadvyatta-op-00b78e597b6e3aa1fd65ffdd7ea1ff2a2ac019d5.tar.gz
vyatta-op-00b78e597b6e3aa1fd65ffdd7ea1ff2a2ac019d5.zip
merge ChangeLog generation, repo info and autoreconf into
debian/autogen.sh that is in turn run from debian/rules
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autogen.sh37
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules41
3 files changed, 63 insertions, 16 deletions
diff --git a/debian/autogen.sh b/debian/autogen.sh
new file mode 100755
index 0000000..ff125d1
--- /dev/null
+++ b/debian/autogen.sh
@@ -0,0 +1,37 @@
+#!/bin/sh
+
+
+if [ -d .git ] ; then
+# generate GNU/Debian format ChangeLog from git log
+
+ rm -f ChangeLog
+
+ if which git2cl >/dev/null ; then
+ git-log --pretty --numstat --summary | git2cl >> ChangeLog
+ else
+ git-log --pretty=short >> ChangeLog
+ fi
+
+# append repository reference
+
+ url=` git repo-config --get remote.origin.url`
+ test "x$url" = "x" && url=`pwd`
+
+ branch=`git-branch --no-color | sed '/^\* /!d; s/^\* //'`
+ test "x$branch" = "x" && branch=master
+
+ sha=`git log --pretty=oneline --no-color -n 1 | cut -c-8`
+ test "x$sha" = "x" && sha=00000000
+
+ echo "$url#$branch-$sha" >> ChangeLog
+
+fi
+
+rm -rf config
+rm -f aclocal.m4 config.guess config.statusconfig.sub configure INSTALL
+
+autoreconf --force --install
+
+rm -f config.sub config.guess
+ln -s /usr/share/misc/config.sub .
+ln -s /usr/share/misc/config.guess .
diff --git a/debian/docs b/debian/docs
index 0e14f42..50bd824 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,3 +1,2 @@
NEWS
README
-VERSION
diff --git a/debian/rules b/debian/rules
index a0e3415..6c633e3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,23 +19,29 @@ PKGDIR=$(CURDIR)/debian/$(PACKAGE)
CFLAGS = -Wall -g
+configure = ./configure
+configure += --host=$(DEB_HOST_GNU_TYPE)
+configure += --build=$(DEB_BUILD_GNU_TYPE)
+configure += --prefix=/opt/vyatta
+configure += --mandir=\$${prefix}/share/man
+configure += --infodir=\$${prefix}/share/info
+configure += CFLAGS="$(CFLAGS)"
+configure += LDFLAGS="-Wl,-z,defs"
+
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
+configure:
+ chmod +x debian/autogen.sh
+ debian/autogen.sh
+
config.status: configure
dh_testdir
- # Add here commands to configure the package.
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess config.guess
-endif
- ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/opt/vyatta --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
-
+ rm -f config.cache
+ $(configure)
build: build-stamp
@@ -44,14 +50,19 @@ build-stamp: config.status
$(MAKE)
touch $@
-clean:
+clean: clean-patched
+
+# Clean everything up, including everything auto-generated
+# at build time that needs not to be kept around in the Debian diff
+clean-patched:
dh_testdir
dh_testroot
- rm -f build-stamp
-
- test -f Makefile && $(MAKE) distclean || true
- rm -f config.sub config.guess
-
+ if test -f Makefile ; then $(MAKE) clean distclean ; fi
+ rm -f build-stamp
+ rm -f config.status config.sub config.guess config.log
+ rm -f aclocal.m4 configure Makefile.in Makefile INSTALL
+ rm -f etc/default/vyatta
+ rm -rf config
dh_clean
install: build