summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac14
-rwxr-xr-xdebian/rules19
2 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 015d730..bb44cfc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,24 +15,10 @@ AC_CONFIG_AUX_DIR([config])
AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
AC_PREFIX_DEFAULT([/opt/vyatta])
-AC_PROG_CC
-AM_PROG_AS
-AM_PROG_CC_C_O
-AC_PROG_LIBTOOL
-AC_PROG_LEX
-AC_PROG_YACC
-
-AC_ARG_ENABLE([nostrip],
- AC_HELP_STRING([--enable-nostrip],
- [include -nostrip option during packaging]),
- [NOSTRIP=-nostrip], [NOSTRIP=])
-
AC_CONFIG_FILES(
[Makefile]
[etc/default/vyatta]
[debian/vyatta-op.postinst])
-AC_SUBST(NOSTRIP)
-
AC_OUTPUT
diff --git a/debian/rules b/debian/rules
index f2e5c13..4db6686 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,30 +9,13 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
PACKAGE=vyatta-op
PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-CFLAGS = -Wall -g
-
configure = ./configure
-configure += --host=$(DEB_HOST_GNU_TYPE)
-configure += --build=$(DEB_BUILD_GNU_TYPE)
configure += --prefix=/opt/vyatta
configure += --mandir=\$${prefix}/share/man
configure += --infodir=\$${prefix}/share/info
-configure += CFLAGS="$(CFLAGS)"
-configure += LDFLAGS="-Wl,-z,defs"
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
configure: configure.ac Makefile.am
chmod +x debian/autogen.sh
@@ -84,8 +67,6 @@ binary-indep: build install
dh_installdocs
dh_install
dh_installdebconf
- dh_link
- dh_strip
dh_compress
dh_fixperms
dh_installdeb