summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules19
2 files changed, 1 insertions, 19 deletions
diff --git a/debian/control b/debian/control
index c124dfa..757332b 100644
--- a/debian/control
+++ b/debian/control
@@ -9,6 +9,7 @@ Package: vyatta-op
Architecture: all
Depends: sed (>= 4.1.5),
ethtool,
+ traceroute,
ntpdate,
procps (>= 1:3.2.7-3),
pciutils,
diff --git a/debian/rules b/debian/rules
index f2e5c13..4db6686 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,30 +9,13 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
PACKAGE=vyatta-op
PKGDIR=$(CURDIR)/debian/$(PACKAGE)
-CFLAGS = -Wall -g
-
configure = ./configure
-configure += --host=$(DEB_HOST_GNU_TYPE)
-configure += --build=$(DEB_BUILD_GNU_TYPE)
configure += --prefix=/opt/vyatta
configure += --mandir=\$${prefix}/share/man
configure += --infodir=\$${prefix}/share/info
-configure += CFLAGS="$(CFLAGS)"
-configure += LDFLAGS="-Wl,-z,defs"
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
configure: configure.ac Makefile.am
chmod +x debian/autogen.sh
@@ -84,8 +67,6 @@ binary-indep: build install
dh_installdocs
dh_install
dh_installdebconf
- dh_link
- dh_strip
dh_compress
dh_fixperms
dh_installdeb