summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorslioch <slioch@eng-140.vyatta.com>2008-12-15 13:45:21 -0800
committerslioch <slioch@eng-140.vyatta.com>2008-12-15 13:45:21 -0800
commita0355005f78f34d3ecc9b88765890e8784068d32 (patch)
tree21c932ff98afe07346caf323c7735500ef96fce1
parentbe9847e0761b8cd13e61ad2558037bfbaf197bee (diff)
downloadvyatta-wanloadbalance-a0355005f78f34d3ecc9b88765890e8784068d32.tar.gz
vyatta-wanloadbalance-a0355005f78f34d3ecc9b88765890e8784068d32.zip
completes work to support dhcp for wan lb.
-rw-r--r--Makefile.am4
-rw-r--r--scripts/dhcp/dhcp-wanlb4
-rw-r--r--templates/load-balancing/wan/interface-health/node.tag/nexthop/node.def2
3 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 81b5f97..19b7e48 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,4 @@
+dhcphookdir = /etc/dhcp3/dhclient-exit-hooks.d
cfgdir = $(datadir)/vyatta-cfg/templates
bin_sudo_usersdir = $(bindir)/sudo-users
curverdir = $(sysconfdir)/config-migrate/current
@@ -15,6 +16,8 @@ sbin_SCRIPTS += scripts/vyatta-wanloadbalance.init
bin_sudo_users_SCRIPTS = scripts/vyatta-wlb-status
bin_sudo_users_SCRIPTS += scripts/vyatta-wlb-connection.pl
+dhcphook_SCRIPTS = scripts/dhcp/dhcp-wanlb
+
curver_DATA = cfg-version/wanloadbalance@1
src_wan_lb_SOURCES = src/main.cc
@@ -32,6 +35,7 @@ cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
install-exec-hook:
+ mkdir -p $(DESTDIR)$(dhcphookdir)
mkdir -p $(DESTDIR)$(cfgdir)
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
find etc ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | cpio -0pd $(DESTDIR) \ No newline at end of file
diff --git a/scripts/dhcp/dhcp-wanlb b/scripts/dhcp/dhcp-wanlb
new file mode 100644
index 0000000..15fc98d
--- /dev/null
+++ b/scripts/dhcp/dhcp-wanlb
@@ -0,0 +1,4 @@
+pid=/var/run/vyatta/wlb.pid
+if [ -f $pid ]
+ kill -s SIGUSR2 $( cat $pid ) 2>/dev/null
+fi
diff --git a/templates/load-balancing/wan/interface-health/node.tag/nexthop/node.def b/templates/load-balancing/wan/interface-health/node.tag/nexthop/node.def
index 34101b6..b549e8c 100644
--- a/templates/load-balancing/wan/interface-health/node.tag/nexthop/node.def
+++ b/templates/load-balancing/wan/interface-health/node.tag/nexthop/node.def
@@ -1,2 +1,2 @@
-type: ipv4
+type: txt
help: Set interface nexthop